Наша команда имеет несколько действующих проектов. Мы оказываем следующие услуги:   Разработка программного обеспечения. Также обслуживаем и автоматизируем программы на платформе 1С. Сайт проекта: moscowsoft.com Разработка графического дизайна: дизайн сайтов, продукции, упаковки, визитки, журналы. Смотрите сайт проекта. Оказание услуг по оформлению праздников и мероприятий: designvanilla.ru.

 

You are here1С8 Макет пример

1С8 Макет пример


1С8 Макет пример

Процедура по заполнению макета:

Процедура ПечатьКурсаУЕ(Кнопка)
    Набор=РегистрыСведений.Курсы.СоздатьНаборЗаписей();
    Набор.Прочитать();
    к=Набор.Количество();
    Для н=0  по к-1 Цикл
        ТекСтрока=Набор[н];
        Сообщить(""+ТекСтрока.Период+Символы.Таб+ТекСтрока.Курс);
    КонецЦикла;
   
    ТабДок=Новый ТабличныйДокумент();
    Макет=ПолучитьОбщийМакет("КурсУЕ");
    Область=Макет.ПолучитьОбласть("Заголовок");
    Область.Параметры.НаименованиеОрганизации=Константы.НаименованиеОрганизации.Получить();
    ТабДок.Вывести(Область);
    Область=Макет.ПолучитьОбласть("Шапка");
    ТабДок.Вывести(Область);
    Область=Макет.ПолучитьОбласть("Строка");
    Набор=Регистрысведений.Курсы.СоздатьНаборЗаписей();
    Набор.Прочитать();
    к=Набор.Количество();
    Для н=0 по к-1 Цикл
        ТекСтрока=Набор[н];
        Область.Параметры.Дата=ТекСтрока.Период;
        Область.Параметры.Значение=ТекСтрока.Курс;
        ТабДок.Вывести(Область);
    КонецЦикла;

ТабДок.ИмяПараметровПечати = "ПараметрыКурсаУЕ";
ТабДок.ИмяСохраненияПоложенияОкна = "ОкноКурсаУЕ";
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.СохранятьСвойстваОтображения = Истина;
ТабДок.ТолькоПросмотр = Истина;
ТабДок.ФиксацияСверху = 3;
ТабДок.Показать("История курса УЕ");
КонецПроцедуры

Сам макет содержит параметры Дата и Значение.

Реклама

 

 

 Стоматологическое оборудование и расходные материалы