Наша команда имеет несколько действующих проектов. Мы оказываем следующие услуги:   Разработка программного обеспечения. Также обслуживаем и автоматизируем программы на платформе 1С. Сайт проекта: moscowsoft.com Разработка графического дизайна: дизайн сайтов, продукции, упаковки, визитки, журналы. Смотрите сайт проекта. Оказание услуг по оформлению праздников и мероприятий: designvanilla.ru.

 

You are hereВывести календарь на форму 1С 8.1

Вывести календарь на форму 1С 8.1


Вывести календарь на форму 1С 8.1

Для того, чтобы вывести на форму календарь, достаточно добавить в форме новый реквизит с типом Дата и указать Вид поля - Поле календаря. При этом если увеличивать размер этого элемента формы, то будет увеличиваться количество месяцев, располагающихся в календаре.

Раскрасить некоторые даты можно в процедуре-обработчике события ПриВыводеПериода():

&НаКлиенте
Процедура КалендарьПриВыводеПериода(Элемент, ОформлениеПериода)
 МассивДат = ПолучитьМассивРегламентированныхДат(Объект.ФинансовыйГод);
 Для Каждого ДатаПериода Из ОформлениеПериода.Даты Цикл
  Если МассивДат.Найти(ДатаПериода.Дата) <> Неопределено Тогда
   ДатаПериода.ЦветФона = webЦвета.БледноЗеленый;
  КонецЕсли;
  Если ДеньНедели(ДатаПериода.Дата)>=6 Тогда
   ДатаПериода.ЦветТекста = webЦвета.Красный; 
  КонецЕсли;
  
 КонецЦикла;

КонецПроцедуры
 

Реклама

 

 

 Стоматологическое оборудование и расходные материалы